В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Enot811
Enot811
12.11.2022 20:41 •  Информатика

C++ треугольник паскаля
Треугольник Паскаля строится следующим образом. Первая строка состоит из одного числа, равного единице. Каждая следующая содержит на одно число больше, чем предыдущая. Первое и последнее из этих чисел равны 1, а все остальные вычисляются как сумма числа, стоящего в предыдущей строке над ним и числа, стоящего в предыдущей же строке слева от него.

Входные данные.
Записано одно число N (0 ≤ N ≤ 30).

Выходные данные.
Вывести N строк треугольника Паскаля.

Примечание. Все числа в треугольнике Паскаля при указанных ограничениях входят в integer.

Пример входных данных
8

Пример выходных данных понять не могу

Ответ:
куся26
куся26
12.10.2020 12:06

#include <iostream>

using namespace std;

                   

double Cnk(int N,int K){

return ( (N<K) ? 0 : ((K==0) ? 1 : ((N-K+1) / double(K) * Cnk(N,K-1))) );

}

                 

int main(){

   int n;

   cin>>n;

for (int j = 0; j <= n; j++) {

 for (int i=0; i <=j ; i++)

  cout<<Cnk(j,i)<<" ";

 cout<<"\n";

}

   std::cin.get();

   std::cin.get();

   return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?