В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Galinachlen
Galinachlen
06.02.2022 09:25 •  Информатика

Дан целочисленный массив с количеством элементов n. выведете на печать те его элементы. индексы которых являются степенями двойки. написать программу в паскале

Ответ:
sara6yjfhjh9
sara6yjfhjh9
05.07.2020 14:58

program raf105;

const

 n = 99;

var

 a: array[1..n] of integer;

 i,i2: integer;

begin

 write('Исходный массив: ');

 for i:= 1 to n do

 begin

   a[i]:= random(10,99);

   write(a[i],' ');

 end;

 writeln;

 writeln('Вывод: ');

 for i:=2 to n do

 begin

   i2:= i;

   while (i2 mod 2 = 0) and (i2 <> 0) do

     i2:= i2 div 2;

   if i2 = 1

     then writeln(a[i]:2,' (индекс ',i:2,')');

 end;

end.

PascalABC
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?