Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
Хаченок1337
17.06.2021 20:08 •
Информатика
Дан массив из n чисел найти сумму тех чисел у которых нечетный индехс и числа кратны 5 или 3
Ответ:
Anastasiya12377
05.07.2020 09:49
Var a:array[1..100000] of integer;
s,i,n:integer;
begin
readln(n);
for i:=1 to n do begin
read(a[i]);
if (i mod 2 <> 0) and ((a[i] mod 5 = 0) or (a[i] mod 3 = 0)) then s+=a[i];
end;
writeln(s);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
polinasmi1
22.06.2022 11:04
2по программированию (много 1) три точки заданы своими координатами (x1,y1), (x2,y2), (x3,y3). напишите программу, позволяющую выяснить, какие из них находятся на максимальном...
Александрик397
06.05.2022 01:22
Проверить возможность построения треугольника из отрезков заданной длины, узнать вид треугольника(прямоугольный, остроугольный, тупоугольный)...
oleg1836
13.02.2022 10:29
Дан массив целых чисел b[n]. заполнен с клавиатуры. обработать массив в соответствии с . - подсчитать сумму всех нечетных элементов. - в массиве все элементы, стоящие...
9999Ksenya999
16.06.2020 18:58
На судне рядом расположены 4 каюты, в которых живут 4 матроса: виталий, степан, федот и игнат. известно, что каждый из них владеет ровно одной из следующих морских профессий:...
Vitalikprofi
03.04.2020 02:02
Пример двух классов объекты которых находятся в отношении...
sayana7
03.04.2020 02:02
Назовите устройства мультимедийной обработки информации (по информатике)....
оеавц
03.11.2020 21:27
Памагите решить дробно рациональныое уравнения...
АлинаКравченко
12.11.2020 17:35
1. Преобразуйте выражение в многочлен стандартного вида и определите его степень: а) За + 75 – За + Sab + 2а +а+ 352 - 66 – Заb – 352 – 2ab; б) За(4а + 3Ь) — 9ba – b)...
52681
29.09.2020 06:55
Назвіть характерні ознаки українського бароко втілювали традицi народного A) дерев яного будівництва в) у iх вигляді панує міра та смак Б) позбавлені надмірної декоративності...
dasha148ttt
25.04.2020 08:08
Возведение в квадрат суммы: (3х^2+х)^2 Из-за квадрата в скобке не пойму, как делать...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
s,i,n:integer;
begin
readln(n);
for i:=1 to n do begin
read(a[i]);
if (i mod 2 <> 0) and ((a[i] mod 5 = 0) or (a[i] mod 3 = 0)) then s+=a[i];
end;
writeln(s);
end.