В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
polinasmi1
polinasmi1
22.06.2022 11:04 •  Информатика

2по программированию (много 1) три точки заданы своими координатами (x1,y1), (x2,y2), (x3,y3). напишите программу, позволяющую выяснить, какие из них находятся на максимальном расстоянии друг от друга, и вывести на печать значение этого расстояния. вычисление расстояния между двумя точками оформите в виде процедуры. 2) даны действительные числа х и y. напишите программу, позволяющую вычислить значение следующего выражения: z=(signx + signy)*sign(x+y), определив и используя функцию: sign(a)=0 при a=0 sign(a)=-1 при a< 0 sign(a)=1 при a> 0.

Ответ:
elezavetkavtoray
elezavetkavtoray
29.06.2020 23:53
Program cgt;
var x1,y1,x2,a,y2,b,c,x3,y3:real;
procedure IOI(x1,y1,x2,y2:real;var a:real);
begin
a:=sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2));
end;
begin
read(x1,x2,y1,y2,x3,y3);
IOI(x1,y1,x2,y2,a);
IOI(x1,y1,x3,y3,b);
IOI(x3,y3,x2,y2,c);
if(a>=b)and(a>=c)then writeln('первая и вторая точка ',a) else
if(b>=a)and(b>=c)then writeln('первая и третая точка ',b) else
if(c>=b)and(c>=a)then writeln('третая и вторая точка ',c);
end.
2)
program cgt;
var z,x,y:real;function IOI(x:real):real;
begin
if(x=0)then IOI:=0;
if(x<0)then IOI:=-1;
if(x>0)then IOI:=1;
end;
begin
read(x,y);
z:=(IOI(x)+IOI(Y))*IOI(x+y);
writeln(z);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?