В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
bondiserj
bondiserj
15.05.2022 00:07 •  Информатика

Напишите программу которая запрашивает трёхзначное число получает из него перевёрнутое число и выводит его на экран информатика 8 класс, !

Ответ:
BlacYT
BlacYT
25.05.2020 02:51

1 задача

program proga;

var st,st2:string;

i:Integer;

begin

writeln('Введите число');

readln(st);

for i:=1 to length(st) do begin

st2:=st[i];

write(st2,' ');

end;

end.

2 задача

program proga2;

var st,st2:string;

i,a:Integer;

begin

writeln('Введите возраст');

readln(a);

if a>120 then

writeln('Неверные данные');

if a=1 then

writeln(a,' год');

if (a>1) and (a<5) then

writeln(a,' года');

if((a mod 10 = 1) and (a div 10 <> 0 or 11 )) then writeln(a,' год');

if (a>=5) and (a mod 10 <> 2 or 3 or 4)and (a div 10 <> 10) then

writeln(a,' лет');

if (a<=5) and (a mod 10 = 2 or 3 or 4)and (a div 10 = 10) then writeln(a,' года ');

if(a>104) and (a<110)then writeln(a,' лет');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?