В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
vikulya30
vikulya30
23.04.2023 02:22 •  Информатика

Составить программу заполнения массива случайными числами в диапазоне -30 до 30 и определяет количество чётных элементов массива.​

Ответ:
violettasergeevna
violettasergeevna
11.02.2021 18:55

//Составить программу заполнения массива случайными числами в диапазоне -30 до 30 и определяет количество чётных элементов массива.​

program massiv;

const N=20;

var m:array[1..n] of integer;// поставил 20 элементов массива

   i:byte;

   count:integer;

BEGIN

//заполнение случайными числа в диапазоне [-30;30]

//random(61) выдает случ. значение от 0 до 60, если вычесть -30 с концов этого отрезка получится от -30 до 30

for i:=1 to n do m[i]:=random(61)-30;

//вывод  полученного массива на экран

writeln('Полученный массив');

for i:=1 to n do write(m[i],' ');

writeln;//переход на следующую строку

//сортировка пузырковым методом

for i:=1 to n do

    if (m[i] mod 2=0) then count:=count+1;

writeln('Кол-во четных элементов = ', count);  

END.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?