В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Напишите программу, которая вводила бы с клавиатуры 10 вещественных чисел и вычисляла бы их среднее арифметическое в pascal

Ответ:
MashaSay
MashaSay
03.07.2020 13:21
Program Lemonly;
const
  n=10;
var
  table: array [1..n] of real;
  i: integer;
  sum,arifm: real;
begin
  randomize;
  sum:=0;
  writeln ('Введите ', n, ' чисел:');
 for i:= 1 to n do
    begin
    readln(table[i]);
    sum:=sum+table[i];
    end;
  writeln();
  arifm:=sum/n;
  writeln ('Cреднее арифметическое введённых чисел равно ',arifm:8:3);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?