В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
iskandarova174
iskandarova174
17.11.2022 22:10 •  Информатика

Составить программу для вычисления f=c+(a+b)/(a*b+1) a-наименьший элемент массива; в-количество отрицательных элементов массива; с-количество элементов массива, меньших d(вывести d с клавиатуры). полученные значения элементов a,b,c,f, вывести на печать.

Ответ:
сайнорбой
сайнорбой
28.06.2020 11:07
Var
 v:array[1..10]of integer;
f:real;
i:byte;
a,b,c,d,min,k:integer;
begin
for i:=1 to 10 do 
v[i]:=random(20)-10;
readln(d);
min:=v[1];
b:=0;
for i:=1 to 10 do begin
if v[i]<0 then begin
b:=b+1;
end;
if v[i]>min then
a:=min;
end;
k:=0;
for i:=1 to 10 do begin
if v[i]<d then
k:=k+1;
end;
c:=k;
writeln('наименьший элемент =', a);
writeln('количество отрицательных элементов =', b);
writeln('количество элементов меньших d =', c);
f:=c+(a+b)/(a*b+1);writeln(f);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?