В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
linovaya
linovaya
30.03.2021 22:31 •  Информатика

Информатика - : составить программу, в которой с клавиатуры вводятся два текстовых выражения. необходимо: 1) выбрать и вывести на экран более длинное из них 2) проверить и вывести на экран то из них, у которого первая и вторая буквы - одинаковая (регистр букв можно не учитывать) 3) проверить, входит ли короткое слово в состав длинного 4) вставить в короткое слово на чётные позиции буквы "а" дополнительно к тому, что есть 5) подсчитать суммы кодов символов, использованных в длинном слове

Ответ:
sashatitsky
sashatitsky
05.10.2020 21:29
// PascalABC.NET 3.2, сборка 1407 от 18.03.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var s1:=ReadlnString('Первое слово:');
  var s2:=ReadlnString('Второе слово:');
  // #1
  Writeln('Задание 1) ',s1.Length>s2.Length?s1:s2);
  // #2
  if s1[1]=s1[2] then Writeln('Задание 2) ',s1);
  if s2[1]=s2[2] then Writeln('Задание 2) ',s2);
  // #3
  Write('Задание 3) Более короткое слово ');
  // предполагаем, что s1 более короткое.
  // Если это не так, меняем их местами.
  if s1.Length>s2.Length then Swap(s1,s2);
  if pos(s1,s2)=0 then Write('не');
  Writeln(' входит в более длиное');
  // #4
  s1:=s1.ToCharArray.Select((c,i)->i mod 2<>0?'a'+c:c).JoinIntoString('');
  Writeln('Задание 4) ',s1);
  // #5
  Writeln('Задание 5) Сумма кодов (в UNICODE) для длинного слова: ',
      s2.ToCharArray.Select(c->integer(Ord(c))).Sum)
end.

Примеры
Первое слово: Колокольчик однозвучный утомительно звенит
Второе слово: дно
Задание 1) Колокольчик однозвучный утомительно звенит
Задание 3) Более короткое слово  входит в более длиное
Задание 4) дaно
Задание 5) Сумма кодов (в UNICODE) для длинного слова: 42383

Первое слово: ссора
Второе слово: рессора
Задание 1) рессора
Задание 2) ссора
Задание 3) Более короткое слово  входит в более длиное
Задание 4) сaсоaра
Задание 5) Сумма кодов (в UNICODE) для длинного слова: 7589
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?