В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
ivanBashak1
ivanBashak1
12.07.2021 20:32 •  Информатика

Нужно написать программу, где нужно ввести число N. Среди N чисел, которые введет пользователь, нужно найти наибольшее число и сумму цифр этого число.

Ответ:
Katyamanubata
Katyamanubata
17.07.2021 12:20

program XieLian;

var n,max ,sum, i:integer;

var A: array [1..100] of integer;

begin

writeln('введите количество чисел');

readln(N);

if (n<=0) then

writeln('ошибка')

else

for i:=1 to n do

begin

write('A[',i,']=');

readln(A[i]);

end;

writeln('введенная строка');

for i:=1 to n do

write(A[i]);

writeln;

max:=A[1];

for i:=1 to n do

if A[i]>max then

max:=A[i];

writeln(max,' -большее число');

sum := 0;

while max > 0 do

begin

sum := sum + max mod 10;

Max := max div 10;

end;

writeln(sum,' -сумма');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?