В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
VadimOMG
VadimOMG
31.07.2022 14:24 •  Информатика

Написать программу определения суммы двух введенных с клавиатуры чисел. (1 ) составить алгоритм и написать программу для нахождения суммы членов ряда (2 ): s = 5 + 6 + 7 + 8 + 9 + + 28 написать программу определения суммы цифр и количества цифр в заданном натуральном числе. (3 )

Ответ:
fivmif
fivmif
22.06.2020 14:13
Ээм.. а на каком языке написать то надо?))
0,0(0 оценок)
Ответ:
Лиза4217
Лиза4217
22.06.2020 14:13
Program Sum;
Var a, b: Integer;
Begin
Write('a = ');
ReadLn(a);
Write('b = ');
ReadLn(b);
WriteLn('Сумма a и b равна ', a + b);
ReadLn;
End.

Program SumRow;
Const min = 5; max = 28;
Var a, i: Integer;
Begin
a := 0;
For i := min To max Do
a := a + i;
WriteLn('Сумма ряда равна ', a);
ReadLn;
End.

Program Digit;
Var a, b: LongInt;
c, d, i: Integer;
Begin
Write('a = ');
ReadLn(a);
b := 1;
c := 0;
While a Div b <> 0 Do
Begin
c := c + 1;
b := b * 10;
End;
While a > 0 Do
Begin
d := d + (a Mod 10);
a := a Div 10;
End;
WriteLn('Количество цифр в числе равно ', c);
WriteLn('Сумма цифр числа равна ', d);
ReadLn;
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?