В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
ulianakosovska0
ulianakosovska0
09.04.2023 19:30 •  Информатика

Составьте программу, вычисляющую для двух дробей a/b и c/d (a,b,c,d - натуральные числа): деление умножение сложение. результат представить в виде простых несократимых дробей в виде функции. pascal

Ответ:
isaev40daniil14
isaev40daniil14
01.10.2020 21:30
Как-то так)

var a,b,c,d,e,f:integer;
function nod(m,n:integer):integer;
begin
while m<>n do
if m>n then m:=m-n
       else n:=n-m;
nod:=m
end;
begin
write('введите числитель1, знаменатель1, числитель2, знаменатель2');
readln(a,b,c,d);
e:=a*d+b*c;
f:=b*d;
 if f=0 then write('на 0 делить нельзя')
else
if e=0 then writeln('сложение =  ',e) 
      else begin
       e:=e div nod(abs(e),f); 
       f:=f div nod(abs(e),f); 
       writeln('сложение =  ',e,'\',f); 
       end;
e:=a*c;
f:=b*d;
 if f=0 then write('на 0 делить нельзя')
else
if e=0 then writeln('умножение = ',e)
else begin
 e:=e div nod(abs(e),f);
       f:=f div nod(abs(e),f);
       writeln('умножение =  ',e,'\',f);
         end;
e:=a*d;
f:=b*c;
if f=0 then write('на 0 делить нельзя')
else
         if e=0 then writeln('деление=  ',e)
else begin e:=e div nod(abs(e),f);
       f:=f div nod(abs(e),f);
       writeln('деление =  ',e,'\',f); 
        end; 
     end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?