В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
katerina200219v
katerina200219v
02.06.2020 23:10 •  Информатика

Дан двумерный массив целых чисел. написать программу, которая: определяет номер последнего столбца, у которого нечетных элементов больше чем четных.(паскаль)

Ответ:
даниил740
даниил740
21.06.2020 18:47

program raf105;

const

 n = 5;

var  

 a: array[1..n,1..n] of integer;

 i,j,num,n1,n2: integer;

begin

writeln('Вводите числа столбцов матрицы по очереди');

for i:=1 to n do

begin

 writeln('Столбец ',i);

 for j:=1 to n do

   readln(a[i,j]);

end;

for i:=1 to n do

begin

 n1:= 0;

 n2:= 0;

 for j:=1 to n do

 begin

   if (a[i,j] mod 2 <> 0) and (a[i,j] <> 0)

     then n1:= n1+1;

 end;

 for j:=1 to n do

 begin

   if (a[i,j] mod 2 = 0) and (a[i,j] <> 0)

     then n2:= n2+1;

 end;

 if n1 > n2

   then num:= i;

end;

writeln('Вывод: ',num);

end.

PascalABC 3.4.2
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?