В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
котя382
котя382
04.06.2021 21:17 •  Информатика

1. составить программу вычесления значения функций у по формуле у = 3cos(5x) , для которой значение аргумента х введите с клавиатуры. 2.составьте программу для решения слкдующей . ежедневно молочная ферма надаивает х л молока.найдите количество молока, полученный за b дней. 3 дано двузначное число. вывести вначале его левую цифру(десятки, а затем - его правую цифру(еденицы). для нахождения десятков использовать операциюделения нацело, для нахождения едениц - операцию взятия остатка от деления. 4. дано целое число, большее 999. используя одну операцию деления нацело и одну операцию взятия остатка от деления, найти цифру, соответсвующую разряду сотен в записи этого числа. 5. выведите с клавиатуры два числа: а и в. если лба числа четные, то вычеслите их сумму и выведите результат на экран. если оба - нечетные,то найдите произведение этих чисел и выведите результат. иначе, увеличьте все числа в пять раз и выведите результаты.

Ответ:
Даня1221
Даня1221
02.10.2020 07:37
1.
var
x:integer;
y:real;
begin
write('Введите значение аргумента "X" : ');
readln(x);
y:=3*cos((5*x));
writeln('Значение функции "Y" = ',y);
readln;
end.

2.
var
x,b:integer;
begin
write('Введите количество молока, полученного за день, л : ');
readln(x);
write('Введите количество дней : ');
readln(b);
writeln('Количество молока, полученного за заданный промежуток времени = ',x*b);
readln;
end.  

3.
var
a,b,c:integer;
begin
write('Введите двузначное число: ');
readln(a);
b:=a div 10;
c:=a mod 10;
writeln(b,#10,c);
end.

4.
var
b:integer;
a:longint;
begin
write('Введите целое число: ');
readln(a);
  b:=a div 100 mod 100;
writeln(b);
readln;
end.

5. 
var
a,b:integer;
begin
write('Введите числа : ');
readln(a,b);
if a and b mod 2=0 then
 writeln(a+b);
if a and b mod 2<>0 then
 writeln(a*b);
readln;
end.
{Про последнее "Иначе", увеличьте все числа в пять раз и выведите результаты" не очень понялЕсли оба чётные - сумма, если оба - нечётные - то произведение. А если иначе, то число должно быть равно нулю. Смысл увеличивать его в пять раз?)}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?