В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Satana04
Satana04
19.03.2022 06:36 •  Информатика

Python Turtle Написать программу для создания персонажей


Python Turtle Написать программу для создания персонажей

Ответ:
yuyornevzkoxkdhd543
yuyornevzkoxkdhd543
16.05.2021 11:53

import turtle

from math import tan, sqrt, pi

def prepare(x, y, color):

   turtle.penup()

   turtle.goto(x, y)

   turtle.pendown()

   turtle.color(color)

   turtle.begin_fill()

def draw_polygon(num_sides, side_length):

   angle = 360.0 / num_sides

   for i in range(num_sides):

       turtle.forward(side_length)

       turtle.right(angle)

   turtle.end_fill()

def calc_s(num_sides, side_length):

   return num_sides * side_length ** 2 / (4 * tan(pi/num_sides))

def calc_side(square):

   return sqrt(4 * square * tan(pi/num_sides) / num_sides)

turtle.hideturtle()

turtle.speed(10)

colors = ['red', 'green', 'blue', 'cyan', 'magenta', 'black', 'yellow', 'pink', 'brown']

xcoords = [0, 150, -150, 150, -150, 270, -270, 270, -270]

ycoords = [0, 150, -150, -150, 150, 270, -270, -270, 270]

squares = []

numsides = []

for i in range(9):

   num_sides = i + 3

   square = round(calc_s(num_sides, 100), 2)

   side_length = round(calc_side(10000), 3)

   squares.append(square)

   numsides.append(num_sides)

   print("Углов:", num_sides, "была площадь:", square, "стала длина грани:", side_length,

         "изменение в", round(side_length/100, 2), "раз")

   prepare(xcoords[i], ycoords[i], colors[i])

   draw_polygon(num_sides, side_length)

turtle.exitonclick()

print("Список количество углов:", numsides, end="")

print("Список площади:", squares)

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?