В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Пользователь вводит строку с числами. напишите программу которая выведет все числа, присутствующие в строке, а также выведет максимальное и минимальное число. числом является любая последовательность цифр. если между двумя числами находится знак операции – результатом будет результат вычисления операции. пример: если дана строка: 123_2*14ghfg003sad15/2dasdasd8.10 программа должна вывести: numbers: 123 28 3 7 8 10 max: 123 min: 3 на java.

Ответ:
катя3868
катя3868
05.10.2020 12:36
Import java.util.*;
import java.util.regex.*;
import java.lang.*;
import java.io.*;

class IntInStr
{
public static void main (String[] args) {
try {
BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
String string;
string = br.readLine();
String[] parts = string.split("[^\\d+\\-*/]+");
Vector<Integer> nums = new Vector<Integer>();
for(String part : parts) {
Matcher isnum = Pattern.compile("^\\d+$").matcher(part);
Matcher isnumop = Pattern.compile("^(\\d+)([+*/-])(\\d+)$").matcher(part);
if (isnum.matches()) {
int ipart = Integer.parseInt(part);
nums.add(ipart);
}
if (isnumop.matches()) {
int l = Integer.parseInt(isnumop.group(1)),
r = Integer.parseInt(isnumop.group(3)),
res;
String operation = isnumop.group(2);
switch(operation) {
case "+":
res = l + r;
break;
case "-":
res = l - r;
break;
case "*":
res = l * r;
break;
case "/":
res = l / r;
break;
default:
throw new ArithmeticException("token parse error");
}
nums.add(res);
}
}
int min = nums.get(0), max = nums.get(0);
System.out.println("Numbers:");
for (int n : nums) {
System.out.println(n);
if (n > max) {
max = n;
}
if (n < min) {
min = n;
}
}
System.out.format("Max: %d%nMin: %d%n", max, min);
} catch(Exception e) {
System.out.println(e.getMessage());
}
}
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?