В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
CagBak
CagBak
12.03.2020 02:37 •  Информатика

Составьте программу определения в массиве B(30) минимального элемента и его номера.

Ответ:
SkylloutBrain
SkylloutBrain
15.10.2020 15:09
var n, i: integer; B: array [1..30] of integer;begin Randomize; n := 1; for i := 1 to 30 do begin    B[i] := Random(100);  Write(B[i], ' ');  if B[i]<B[n] then n := i; end; Writeln; Writeln('Номер: ', n); Write('Элемент: ', B[n]); end.

PascalABC.NET:

begin var B := ArrRandom(30, -99, 99); var n := B.IndexMin; B.Println; Println('Номер:', n+1); Print('Элемент:', B[n])end.

Пример работы:


Составьте программу определения в массиве B(30) минимального элемента и его номера.
Составьте программу определения в массиве B(30) минимального элемента и его номера.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?