В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Skotonyaka
Skotonyaka
19.05.2023 15:27 •  Информатика

1.составте программу для нахождения граммов g в x унциях (1 унция = 28,35 грамма). исходное количиство граммов задается с клавиатуры. 2.напишите программу нахождения длин медиан m1, m2 и m3 треугольника по указанным формулам. длины сторон a,b и c с клавиатуры. m1= m2= m3=

Ответ:
яло203
яло203
18.06.2020 22:45
Const 
    x = 28.35;
var
    g : Real;
begin
    Write('Введите кол-во граммов: ');
    ReadLn(g);

    Writeln(g:0:3, ' грамм = ', g/x:0:3, ' унций.');
    Readln;
end.

2:

var 
    a, b, c : Integer; 
    m : Real;
begin
    Write('Введите сторону a: ');
    ReadLn(a);

    Write('Введите сторону b: ');
    ReadLn(b);

    Write('Введите сторону c: ');
    ReadLn(c);

    m := sqrt(2*sqr(b) + 2*sqr(c) - sqr(a))/2;
    Writeln('Медиана к стороне a = ', m:0:3);

    m := sqrt(2*sqr(a) + 2*sqr(c) - sqr(b))/2;
    Writeln('Медиана к стороне b = ', m:0:3);

    m := sqrt(2*sqr(a) + 2*sqr(b) - sqr(c))/2;
    Writeln('Медиана к стороне с = ', m:0:3);
    Readln;
end.

m = \frac{1}{2} \sqrt{2 b^{2} + 2 c^{2} - a^{2}}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?