В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
pavlon4kp0bmeh
pavlon4kp0bmeh
10.05.2021 18:55 •  Информатика

До 15.03.2021 21:00 Задача 1. Заполните массив A первыми N натуральными числами.

Задача 2. Заполнить массив A первыми N числами, равными степени числа 2. Например: 2, 4, 8, и т.д.

Задача 3. Дан целочисленный массив a из 15 элементов. Написать программу инициализирующую его значениями случайных чисел из диапазона от -20 до +10. Содержимое массива вывести на экран.

Задача 4. Дан вещественный массив a из 20 элементов. Написать программу инициализирующую его значениями случайных чисел из диапазона от -10 до +15. Содержимое массива вывести на экран.
паскаль

Ответ:
momreomgr
momreomgr
15.03.2021 15:10

1.

const N = 10;

var a: array [1..N] of integer;

i, x: integer;

begin

  write('Введите x: ');

  readln(x);

  for i := 1 to N do

  begin

      a[i] := x + i - 1;

      write(a[i], ' ');

  end;

end.

2.

const N = 10;

var a: array [1..N] of integer;

i: integer;

begin

  a[1] := 1;

  a[2] := 1;

  for i := 3 to N do

  begin

      a[i] := a[i-1] + a[i-2];

  end;

  for i := 1 to N do

  begin

      write(a[i], ' ');

  end;

end.

3.

const N = 6;

var a: array [1..N] of integer;

i, x: integer;

begin

  a[N] := 1;

  for i := N-1 downto 1 do

  begin

      a[i] := 2 * a[i+1];

  end;

   

  for i := 1 to N do

  begin

      write(a[i], ' ');

  end;

end.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?