В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
aram0071
aram0071
04.11.2022 19:48 •  Информатика

Напишите программу, которая выводит все простые числа в диапазоне от 2 до N включительно ( 2 ≤ N ≤ 100000 ).

Ответ:
togrul654
togrul654
02.03.2021 21:50

var

N,i,k,x:integer;

begin

readln(N);

for i:=2 to N do

begin

 x:=0;  

for k:=2 to trunc(sqrt(i)) do

   if i mod k=0 then  

   x:=1;

if x=0 then  

write(i,' ');

end;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?