В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
taske047Ataske
taske047Ataske
14.12.2020 05:34 •  Информатика

Программирование с условным оператором
Коробочка имеет форму прямоугольного параллелепипеда с размерами X, Y, Z радиусом R. Составить программу, которая при указанных данных напечатает результат и какой стороной влезет.
Пример: ввести размеры и радиус: X=3, Y=5, Z=7, R=10
Составить условие для проверки прохождения коробочки.
Печать ответа: "Коробочка влезет" или "Коробочка не влезет"

Ответ:

program box;

var

 x, y, z, r: integer;

 d: real;

begin

 writeln('Введите первую сторону коробочки');

 readln(x);

 writeln('Введите вторую сторону коробочки');

 readln(y);

 writeln('Введите третью сторону коробочки');

 readln(z);

 writeln('Введите радиус отверстия');

 readln(r);

 d := r * 2;

 if (sqrt(x * y * z) <= d) then writeln('Коробочка пройдет в круглое отверсие радиуса ', r)

 else writeln('Коробочка не пройдет в круглое отверстие радиуса ', r);

 readln;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?