В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
volfxeniya
volfxeniya
04.04.2023 00:40 •  Информатика

Составить программу, используя двумерные массивы: Найти сумму нечетных
цифр строки у которого второй элемент больше
первого.
(Pascal)​

Ответ:
jokerreal30
jokerreal30
27.02.2021 00:27

var

 a: array[,] of integer;

 m, n, i, j, k, sum: integer;

begin

 Write('Введите размер матрицы M и N: '); ReadLn(m, n);

 SetLength(a, m, n);

 randomize;

 k := - 1;

 WriteLn('Массив:');

 for i := 0 to m - 1 do

 begin  

   for j := 0 to n - 1 do

   begin

     a[i, j] := random(100);

     Write(a[i, j]:4);

   end;

   WriteLn;

 end;

 for i := 0 to m - 1 do

    if (a[i, 1] > a[i,0]) and (k = -1) then k := i;

 if k = -1 then

 begin

   WriteLn('Нет строк, у которых второй элемент больше первого');

   exit;

 end;

 for j := 0 to n - 1 do

    if (a[k, j] mod 2 = 1) then sum := sum + a[k, j];

 WriteLn('Сумма нечетных чисел строки, у которой второй элемент больше первого, равна ', sum);

end.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?