В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
rauf2007
rauf2007
19.03.2023 19:13 •  Информатика

Найти ! 1. "дано число, определить количество четных цифр." program task3; var a, ost, k: integer; begin write ('ввести число a -> '); read (a); k: =0; while a< > 0 do begin ost: = a mod 10; if ost div 2 = 0 then k: =k+1; end; writeln (k); end. 2. "ученики 4 класса вели дневники наблюдения за погодой и ежедневно записывали в дневник температуру. найти среднюю температуру для дней с температурой выше 0 градусов. определите количество дней. программа получает на выход количество дней, в течении которых проводится наблюдение." program task4; var a, s, t, y, k: integer; n: real; begin write ('введи количество дней -> '); read (a); k: =1; s: =0; t: =y; repeat write ('введи температуру в ',k,'-ый день'); read (y); if a> 31 then write ('количество дней в месяце меньше 31'); if t> 0 then k: =k+1; if t> 0 then s: =s+t; if t=y then write ('k=',k); write ('s=',s); until t=y; if t=y then n: =s/k; writeln ('n=',n); end.

Ответ:
annaphilatovp06jxq
annaphilatovp06jxq
01.10.2020 02:10

1) Program task3;
var a, ost, k: integer;
begin
write (Ввести число a ->'); read (a);
k:=0;
while a<>0 do begin
ost:= a mod 10;
if ost mod 2 = 0 then k:=k+1;
a := a div 10
end;
writeln (k); 
end. 

 

2)  Эту не знала как исправить, поэтому в основном просто переписала :)

Program task4;
var a, s, t, i, k: integer; n: real;
begin
write ('Введи кол-во дней -> ');
readln (a);
k:=0;
s:=0;
For i := 1 to a do
begin
write ('введи температуру в  ',i,-ый день');
readln(t);
if t>0 then
begin
k:=k+1;
s:=s+t;
end;
end;
writeln('Кол-во дней, в течение которых проводилось наблюдение ', a);
writeln('Кол-во дней с  t>0 = ', k);
n:=s/k;
writeln (Средняя температура в дни с  t>0 ',n)
end.

 

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?