В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Составьте программу, которая меняет местами максимальный и минимальный элементы массива и выводит на экран исходный и преобразованный массивы. Все элементы массива различны, и их значения вводятся с клавиатуры.

Ответ:
милка326
милка326
24.12.2020 13:08

#include <iostream>

#include <iomanip>

#include <ctime>

using namespace std;

int main()

{

   setlocale(LC_ALL, "russian");

   int max = 0;

   int min = 0;

   int Indexmin2;

   int Indexmax = 0, Indexmin = 0;

   const int N = 10;

   int array[N];

   int i;

   for (i = 0; i < N; i++)

   {

       cin >> array[i];

   }

   cout << endl;

   cout << " Результат до перестановки " << endl;

   for (i = 0; i < N; i++)

   {

       cout << setw(5) << array[i];

   }

   cout << endl;

   cout << " Результат после перестановки " << endl;

   for (i = 0; i < N; i++)

   {

       if (array[i] > max)

       {

           max = array[i];

           Indexmax = i;

       }

       if (array[i] < min)

       {

           min = array[i];

           Indexmin = i;

       }

   }

   Indexmin2 = array[Indexmin];

   array[Indexmin] = array[Indexmax];

   array[Indexmax] = Indexmin2;

   for (i = 0; i < N; i++)

   {

       cout << setw(5) << array[i];

   }

   cout << endl;

   cout << "Максимальное: " << max << endl;

   cout << "Минимальное: " << min << endl;

   cout << "Максимальный индекс: " << Indexmax << endl;

   cout << "Минимальный индекс: " << Indexmin << endl;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?