В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
sergey000910
sergey000910
30.12.2021 17:31 •  Информатика

НАДО написать оператор Repeat-Untill)

программа загадывает случайное число в диапазоне от 1 до 100.Написать программу,позволяющая пользователю угадать заданное число за неизвестное количество попыток. если пользователь будет вводить число,меньше загаданного,тогда появится на экране подсказка "больше",и наоборот-если число будет больше загаданного появляется подсказка "меньше".Если он угадывает число за количество попыток меньше 7,тогда появляется надпись "молодец",если больше 7 - "плохо"

Ответ:
Аня20031204
Аня20031204
14.10.2020 10:21

var a,b,c: real;

begin

 c:=0;

 a:=random (100);  

 repeat  readln(b); if b<a then begin writeln('больше') ;c:=c+1;end else if b>a then begin writeln('меньше') ;c:=c+1  end until b=a;

 if c<7 then writeln('молодец') else writeln('плохо')

 end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?