В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
svetlanaGB
svetlanaGB
01.11.2021 20:10 •  Информатика

C++ Напишите программу, которая определяет, попадает ли заданная точка в
заштрихованную область. Граничные точки входят в область.

Формат входных данных
Вводится целое число х, которое по модулю не превосходит 105.
Формат выходных данных
Вывести «1», если координаты точки попадают в данную область, и «О» В противном
случае.
Входные данные
выходные данные
1​


C++ Напишите программу, которая определяет, попадает ли заданная точка взаштрихованную область. Гран

Ответ:
alyamirnaya28
alyamirnaya28
18.11.2020 23:43

#include <iostream>

#include <cmath>

using namespace std;

int main()

{

int x;

cin >> x;

if (abs(x) <= 105)

{

 if (x >= -5 && x <= 1 || x >= 7 && x <=13)

  cout << '1';

 else

  cout << 'O';

}

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?