В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Напишите программу,которая содержит описание типов данных и подпрограмм для обработки одномерногго массива размерностью n , где n< =15.программа должна состоять из подпрограмм: a)ввод элементов массива с клавиатуры b)функции возвращающей сумму четных элементов массива c)функции выводящей на экран минимальный элемент массива

Ответ:
Pechenka100500
Pechenka100500
25.05.2020 22:28

Комментарии:

Вот описание своего типа данных:

type
pArray = array [1..15] of integer;

 

Вот проверка на правильно введенноее значение от 1 до 15:

while (N<1) or (n>15) do, если введешь неправильно спросит еще раз

 

Подпрограммы:

 

 

Ввод элементов массива с клавиатуры здесь: procedure InputArray

Функции возвращающей сумму четных элементов массива: function SummOfEven

Функции выводящей на экран минимальный элемент массива: function MinimalElement




program ArrayProccessor;
uses crt;
type
pArray = array [1..15] of integer;

var myArray: pArray;
N:integer;

procedure InputArray(var arrayToInput:pArray; n:integer);
var i:integer;
begin
for i:=1 to n do
begin
write('vvedite a[',i,']=');
readln(arrayToInput[i]);
end;
end;

function SummOfEven(arrayToProcess:pArray; n:integer):integer;
var i:integer;
res:integer;
begin
res:=0;
for i:=1 to n do
begin
if not odd( arrayToProcess[i]) then res:=res+arrayToProcess[i];

end;
SummOfEven:=res;
end;

function MinimalElement(arrayToProcess: pArray; n:integer):integer;
var i:integer;
res:integer;
begin
res:= arrayToProcess[1];
for i:=2 to n do
begin
if(res>arrayToProcess[i]) then res:=arrayToProcess[i];
end;
MinimalElement:=res;
writeln('minimal element: ', res);
end;

begin
clrscr;
N:=0;
while (N<1) or (n>15) do
begin
write('Vvedite kol-vo elementov massiva ot 1 do 15: ');
readln(N);
end;
InputArray(myArray, n);
writeln('summa chetnih: ', SummOfEven(myArray, n));
MinimalElement(myArray, n);

readln;
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?