В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
FoxEdit
FoxEdit
19.08.2021 23:49 •  Информатика

Составить программу которая считает количество цифр 7 в записи натурального числа.

PASCAL

Ответ:
doncov2001
doncov2001
15.10.2020 00:39

var

 a, count: integer;

begin

 count := 0;

 read(a);

 while a > 0 do

 begin

   if a mod 10 = 7 then

     count := count + 1;

   a := a div 10;

 end;

 writeln(count);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?