В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
trukit
trukit
04.03.2020 09:15 •  Информатика

В массиве хранится информация о стоимости книг . Составить программу, которая выводит на экран номера книг, которые стоят ниже средней стоимости всех этих книг. В C++

Ответ:
HALERIOP
HALERIOP
14.10.2020 23:22

#include <iostream>

using namespace std;

#define ll long long

#define ld long double

signed main(){

   ll n;

   cin >> n;

   ld a[n],sum = 0;

   for(ll i = 0; i < n; i++){

       cin >> a[i];

       sum += a[i];

   }

   ld av = sum/n;

   for(ll i = 0; i < n; i++)

       if(a[i] < av)

           cout << i+1 << " ";

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?