Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
tyrone12
18.10.2021 21:49 •
Информатика
Написать программу решения следующей : определить периметры трѐх треугольников, если заданы координаты их вершин. использовать подпрограмму-функцию
Ответ:
алхожа
01.05.2020 17:44
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 uses crt; var i,xa,ya,xb,yb,xc,yc: integer; function Dlina(x1,y1,x2,y2: integer):real; var d: real; begin d:= sqrt(sqr(y1-y2)+sqr(x1-x2)); Dlina:=d; end; function Perimetr(a,b,c: real): real; begin Perimetr:=a+b+c; end; procedure Vvod (nt: byte; var ax,ay,bx,by,cx,cy: integer); begin writeln ('Координаты вершины A ',nt,' треугольника'); readln (ax,ay); writeln ('Координаты вершины B ',nt,' треугольника'); readln (bx,by); writeln ('Координаты вершины C ',nt,' треугольника'); readln (cx,cy); end; begin for i:=1 to 3 do begin Vvod (i,xa,ya,xb,yb,xc,yc); writeln ('Периметр ',i,' треугольника = ',Perimetr(Dlina(xa,ya,xb,yb),Dlina(xb,yb,xc,yc),Dlina(xc,yc,xa,ya)):0:2); writeln; end; readkey end.
0,0
(0 оценок)
Популярные вопросы: Информатика
zeIenkrist
08.08.2022 18:19
Представить числа в двоичном виде в восьмибитовой ячейке в формате целого без знака 5...
nasa21p08m1i
12.01.2023 20:19
Напишите программу в python: найти максимальную честную цифру в числе...
Адил1111111111
08.08.2022 18:19
Записать выражение в паскалях и вычислить их значение при а=2; в=3 а+в/a^2-b(под корнем); |a|-a+b/a-b...
kvasik032
31.03.2020 05:21
Напишите программу в python: найти сумму цифр 5 в числе....
Jfddddghvvvvgu
04.12.2022 19:21
Надо двоичный код перевести в десятичный 101,101-5,5 1000,1000- 1001,1000- 1011,110- 1100,110- 1100,111- 1011,111- 1011,10- 1001,10- 1001,11 1010,11 1010,100 111,100...
TBONBATYA
28.08.2020 06:48
Дан массив вещественных чисел. каждый элемент, больший 10 заменить на 10 и вывести полученный массив....
eva0056
06.07.2022 01:46
ОЧЕНЬ по горизонтали ответы мне дали. но вот по вертикали забыли(((...
elizaveta66
27.09.2022 00:10
Переведите число 28 с десятичной в полным решением ) 13...
Елька165
14.10.2022 02:10
Написать алгоритм (на языке c# в визуал студио )проверки знания коэффициента свободного падения. в случае неправильного ответа пользователя, алгоритм должен выводить...
komarenko
25.03.2022 13:54
За окном светит солнце или за окном не светит солнце и пасмурно...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?