В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
ksusha290
ksusha290
03.11.2022 00:51 •  Информатика

НАДО

КАК ЕЕ ЗАПИСАТЬ?
напишите программу ,которая выполняет подсчет согласных букв в слове
ВОТ ПРИМЕР КАК ДЕЛАТЬ,НО ЭТО ПОДСЧЕТ С РАЗЛИЧНЫХ БУКВ В СЛОВЕ ​

Ответ:
anastasiiauski
anastasiiauski
02.05.2020 13:30

ответ:{ Составить программу подсчета различных букв в слове. }

var s:string;

r:real;

i,j,n:integer;

begin

r:=0;

readln(s);

for i:=1 to length(s) do begin

n:=0;

for j:=1 to length(s) do begin

if s[i]=s[j] then inc(n);

end;

r:=r+1/n;

end;

writeln('количество различных букв = ', r:1:0);

end.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?