В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Здравствуйте с заданиями по информатике!
1. Составить программу нахождения минимального элемента и его номера в массиве вещественных чисел не более 50, задаваемых вводом с клавиатуры.
2. Сформировать массив (вывести на экран) из т случайных целых чисел на промежутке от -60 до 60, найти сумму чисел больших 20.
3. В массиве подсчитать количество элементов больших, чем 13. Элементов в массиве 14. Целочисленный массив вводится случайным образом в интервале от 3 до 30.

Ответ:
mintotea
mintotea
18.08.2020 08:35

готово

Объяснение:

1)

program minimum;

var

 i, n, k: integer;

 min: real;

 A: array of real;

begin

 Write('Введите размер массива: ');

 ReadLn(n);

 SetLength(A, n);

 for i := 0 to n - 1 do

 begin

   Write('Введите A[',i,']=');

   ReadLn(A[i]);

 end;

 min := A[0];

 for i := 1 to n - 1 do

 if A[i] < min then

   begin

     min := A[i];

     k := i;

   end;

 WriteLn('Минимальный элемент - A[',k,'] = ', min);

end.

2)

program summa;

var

 i, t, sum: integer;

 A: array of integer;

begin

 Write('Введите размер массива: ');

 ReadLn(t);

 SetLength(A, t);

 for i := 0 to t - 1 do

 begin

   A[i] := round(random(120) - 60);

   WriteLn('A[', i, '] = ', A[i]);

   if A[i] > 20 then sum := sum + a[i];

 end;

 WriteLn('Сумма чисел, больших 20 = ', sum);

end.

3)

program massiv;

var

 i, k: integer;

 A: array[0..13] of integer;

begin

 for i := 0 to 13 do

 begin

   A[i] := round(random(27) + 3);

   WriteLn('A[', i, '] = ', A[i]);

   if A[i] > 13 then k := k + 1;

 end;

 WriteLn('Количество чисел, больших 13 равно ', k);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?