В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
vhjklv
vhjklv
01.07.2022 21:20 •  Информатика

Напишите программу паскаль ! в последовательности целых чисел найдите минимальное число и количество его повторений

Ответ:
помагите71
помагите71
10.10.2020 03:58

Var

 Ch, n, Min, kMin: integer;

Begin

 Write('Введите кол-во чисел последовательности: ');

 ReadLn(n);

 

 Min := 0;

 kMin := 0;

 

 WriteLn('Введите целые числа в кол-ве ', n, ' штук:');

 For n := 1 to n do

 Begin

   Read(Ch);

   if (Ch < Min) or (kMin = 0) then

   Begin

     Min := Ch;

     kMin := 1;

   End

   else if (Ch = Min) then

     kMin := kMin + 1;

 End;

 

 WriteLn('Минимальное число: ', Min);

 WriteLn('Кол-во минимальный чисел: ', kMin);

End.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?