В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
kamilyusupov123
kamilyusupov123
29.03.2022 09:15 •  Информатика

5. Исправьте ошибки во фрагменте программы (напишите верный код) и определите, сколько раз выполняются команды цикла и что вычисляется:
for i:=7 to 25 do;
read (a[i])
if a[i] mod 2 <> 0 then begin p:=p*a[i]; k:=k+1;

Ответ:
КираГринРоуз
КираГринРоуз
06.08.2020 17:59

В данном фрагменте программы идёт

1) if (a[i] mod 2 <> 0) - условие: "если элемент массива нечетный, т.е. при делении на 2 есть остаток, то"

2) p:=p*a[i]; -  операция умножения элементов массива. Произведение обозначено p.

3) k:=k+1; - это суммирование, сколько раз выполняется команда

Верно: for i:=7 to 25 do begin

if (a[i] mod 2 <> 0) then begin p := p*a[i]; k:=k+1; end; end;

Объяснение: все ошибки выделены жирным шрифтом.

for i:=7 to 25 do;

read (a[i])

if (a[i] mod 2 <> 0) then begin p:=p*a[i]; k:=k+1; end;

Если в программе поставить знак ; сразу после запроса действия do (сразу после открытие цикла), она не начнёт выполнение условия. Лишним также является read (a[i]), т.к. программе вновь не задаётся цикл, либо её чтение было уже задано до данного цикла с условием.

Если интересна программа полностью, то вот код ниже, а также скриншот с результатами. Заполнение массива задано автоматически числами от 1 до 100. Размерность массива - 25 чисел. При произведении мы всегда задаём значение переменной 1, иначе программа не начнёт операцию, при сложении присваивать значение только 0, но это необязательно.

Program zadacha;

var  

 a: array [1..25] of integer;

 i,p,k: integer;

begin

  for i:=1 to 25 do

  a[i]:= Random(100); // числа от 1 до 100 будут присутствовать в массиве

writeln('Заполненный массив:'); for i := 1 to 25 do write(a[i],' ');

p:=1; k:=0;

for i:=7 to 25 do begin

if (a[i] mod 2 <> 0) then begin p := p*a[i]; k:=k+1; end; end;;

writeln;

writeln('Произведение нечетных элементов:', p);

writeln('Сколько раз выполнилось условие:', k);

end.


5. Исправьте ошибки во фрагменте программы (напишите верный код) и определите, сколько раз выполняют
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?