В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
viktoriya229
viktoriya229
18.05.2022 10:06 •  Информатика

Написать программу, которая вычисляет число x6 с трех операций умножения

Подсказка:

Вычислить рациональным т.е. за минимальное количество операций: y = x6 (y = (x3 ) 2 = (x2 * x) 2 , то есть за 3 операции

Ответ:
liliiayukhno1
liliiayukhno1
12.08.2020 12:38

#include <iostream>

using namespace std;

int main()

{

   

   ///x = x^6 - надо вычеслить за (3) - опирации умножения.

   cout << "x= ";

   int x;

   cin >> x;

   cout << endl;

   

   x = (x * x * x) * 8;///-3 операции умножения

   cout << "X^6=" << x << endl;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?