Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
меаавепеу
21.12.2020 10:34 •
Информатика
Из массива а, состоящего из n целых элементов, получить массив в, в который войдут все элементы массива а, кратные 3.число n и элементы массива а ввести с клавиатуры. на экран вывести массив в.
Ответ:
кошка448
08.10.2020 20:43
Program znanija;
Var
a, res: array of integer;
x, N, i, k: integer;
begin
readln(N);
SetLength(a,N);
SetLength(res,N);
for i := 0 to N - 1 do
readln(a[i]);
k := 0;
for i := 0 to N - 1 do
if a[i] mod 3 = 0 then
begin
res[k] := a[i];
k := k + 1;
end;
for i := 0 to k - 1 do
writeln(res[i]);
end.
0,0
(0 оценок)
Ответ:
JuliaFlar
08.10.2020 20:43
PascalABC.NET 3.4.0, сборка 1671 от 31.05.2018
Внимание! Если программа не работает, обновите версию!
begin
var a:=ReadArrInteger('Вводите:',ReadInteger('n='));
var b:=a.Where(t->t mod 3=0).ToArray; b.Println
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
amikhaylushkina
20.01.2023 06:25
Дано 2 целых положительных числа: a и b. требуется написать программу, которая находит цифру, на которую оканчивается число a^b. входные данные результат a=2 b=4 6...
Колобокхоёк
20.01.2023 06:25
Население города увеличивается на 2% ежегодно. в текущем году оно составляет 50 000 человек. составьте блок-схему алгоритма вычисления предполагаемой численности населения...
ForaN777
15.02.2023 04:41
Известный программист получил от своего друга сообщение, записанное всеми возможными символами используемого ими алфавита: zlxuzx& $no. ответное сообщение содержало...
Kukushka2281337
30.07.2022 22:18
Написать программу вычисления суммы чисел 111, 106, 101, 46 с циклов....
FJcjfjvj
30.07.2022 22:18
Сколько битов информации несет сообщение о том, что из колоды в 32 карты достали пик?...
Ксюшка3215
31.07.2021 00:30
Напишите (отправьте фотографию), что нужно написать в программе pascalabc.net, чтобы создать программу 《 begin1°. дана сторона квадрата a. найти его периметр p=4a》...
azzitop
18.07.2021 10:48
1)выполните сложение двух чисел в двоичной сс. в восмеричной и в шенадцатиричной 55 число...
supervoron
01.04.2022 10:56
Для кодирования нотной записи используется 13 значков. каждый значок кодируется одним и тем же минимально возможным количеством бит. чему равен информационный объем...
avitoritap016iq
25.09.2020 06:32
Сколько различных слов в племени тумбо-юмбо,если нужно всего 5 бит,чтобы закодировать каждое слово? только пишите с решением...
rrrf1
06.04.2021 03:48
Чем фиксипуется координаты курсора текстового редактора?...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Var
a, res: array of integer;
x, N, i, k: integer;
begin
readln(N);
SetLength(a,N);
SetLength(res,N);
for i := 0 to N - 1 do
readln(a[i]);
k := 0;
for i := 0 to N - 1 do
if a[i] mod 3 = 0 then
begin
res[k] := a[i];
k := k + 1;
end;
for i := 0 to k - 1 do
writeln(res[i]);
end.
Внимание! Если программа не работает, обновите версию!
begin
var a:=ReadArrInteger('Вводите:',ReadInteger('n='));
var b:=a.Where(t->t mod 3=0).ToArray; b.Println
end.