В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
rfhbyf23690
rfhbyf23690
01.03.2023 03:21 •  Информатика

Напишите программу на pascalabc - дано слово. переставьте его последнюю букву на место первой. подразумевается при этом, что все последующие буквы будут сдвинуты вправо на одну позицию. вводится строка, состоящая из одного слова (последовательность строчных латинских букв без пробелов) длиной не более 150 символов.

Ответ:
annamironenkosp0dly3
annamironenkosp0dly3
10.10.2020 03:36

var

 str:string;

 s:char;

 i:integer;

Begin

 readln(str);

 s := str[length(str)];

 str := str + '0';

 for i := length(str)-1 downto 1 do begin

   str[i+1] := str[i];

 end;

 str[1] := s;

 delete(str, length(str), 1);

 writeln(str);

End.

жду лучший ответ

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?