В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Luciferiy
Luciferiy
05.01.2021 17:08 •  Информатика

Напишите программу на языке pascal. 1. напишите программу. определяющую, сколько раз в число входит цифра. цифра и число пользователем в начале работы программы. 2. напишите программу, определяющую, равна ли первая цифра числа его последней цифре. 3. запишите алгоритм подсчета суммы, количества и
произведения цифр произвольного целого положительного числа.

Ответ:
Zandrew2000
Zandrew2000
17.08.2020 10:27

1:

var N,k,s:integer;

BEGIN

s:=0;

readln(N,k);

N:=abs(N);

while N>0 do begin

if (N mod 10=k) then

s:=s+1;

N:=N div 10;

end;

writeln(s);

end.

2:

var N:integer;

s:string;

BEGIN

readln(N);

s:=IntToStr(N);

if (s[1]=s[Length(s)]) then

writeln('ДА') else

writeln('НЕТ');

end.

3:

var N,p,s,k:integer;

BEGIN

readln(N);

p:=1;

s:=0;

k:=0;

while N>0 do begin

p:=p*(N mod 10);

s:=s+(N mod 10);

k:=k+1;

N:=N div 10;

end;

writeln('Количество цифр = ',k);

writeln('Сумма цифр = ',s);

writeln('Произведение цифр = ',p);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?