В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
zizizineb99
zizizineb99
26.07.2021 15:59 •  Информатика

Задачи на циклы while . Напишите программу, которая получает на вход положительное число. Если введенное число четное выводятся все четные числа до этого числа, если нечетное выводятся все нечетные числа до этого числа.​

Ответ:
АсяБру
АсяБру
11.10.2020 23:12

var

 n: integer;

 i: integer;

begin

 i := 0;

 writeln('Введите число: ');

 readln(n);

 if n mod 2 = 0 then

   while i < n do

   begin

     i := i + 1;

     if i mod 2 = 0 then

       write(i, ' ')

   end

 else

   while i < n do

   begin

     i := i + 1;

     if i mod 2 <> 0 then

       Write(i, ' ')

   end

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?