В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Dimon22872
Dimon22872
12.01.2020 17:19 •  Информатика

1определите, что будет напечатано в результате работы следующей программы var s, n: integer; begin s : = 0; for n : = 1 to 10 do s : = s + 9; write(s); end. 2 определите, что будет напечатано в результате работы следующей программы var m, n : integer; begin m : = 50; for n : = 1 to 7 do m : = m – 7; write(m); end. 3 определите, что будет напечатано в результате работы следующей программы var s, k: integer; begin s : = 0; for k : = 2 to 9 do s : = s + 2 * k; write(s); end. 4 определите значение переменной с после выполнения следующего фрагмента программы: a : = 30; b : = 6; a : = a / 2 * b; if a > b then c : = a - 12 * b else c : = a + 12 * b; 5 определите значение переменной а после выполнения данного алгоритма: a : = 5 с : = 3 с : = 7 + a * с a : = с / 2 * a

Ответ:
bpanraw
bpanraw
10.10.2020 00:46

1. Программа 10 раз прибавляет 9 к нулю =>

s = 9 * 10 = 90

ответ: 90.

2. Программа 7 раз отнимает 7 от 50 =>

m = 50 - 7 * 7 = 1

ответ: 1.

3. Программа прибавляет удвоенный индекс цикла (от 2 до 9) к нулю

s = 2 * (2 + 3 + 4 + 5 + 6 + 7 + 8 + 9) = 88

ответ: 88.

4.

a = 30; b = 6

a = 30 / 2 * 6 = 15 * 6 = 90; b = 6

a > b = 90 > 6 = true =>

a = 90; c = 90 - 12 * 6 = 90 - 72 = 18

ответ: 18.

5.

a = 5; c = 3

a = 5; c = 7 + 5 * 3 = 7 + 15 = 22

a = 22 / 2 * 5 = 11 * 5 = 55; c = 22

ответ: 55.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?