В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Вариант 3. на¬пишите программу, которая в последовательности натуральных чисел определяет минимальное чётное число. программа получает на вход количество чисел в последовательности, а затем сами числа. в последовательности всегда имеется чётное число. программа должна вывести одно число — минимальное чётное число

Ответ:
Tanya31323
Tanya31323
10.10.2020 00:21

С++ / gcc 7.3.0


#include <iostream>

#include <algorithm>

#include <vector>

int main()

{

   unsigned int N;

   std::cin >> N;

   std::vector<unsigned int> v(N);


   for(unsigned int i = 0; i < N; i++)

       std::cin >> v[i];


   std::sort(v.begin(), v.end());

   for(auto it : v)

   {

       if(it % 2 == 0)

           std::cout << it << std::endl;

       break;

   }

   return 0;

}



Вариант 3. на¬пишите программу, которая в последовательности натуральных чисел определяет минимально
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?