В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
19nadoeloikat1niki
19nadoeloikat1niki
16.10.2022 07:40 •  Информатика

1. напишите программу, которая выводит значение порядкового номера этого значения. 2. напишите программу, которая подсчитывает количество элементов в массиве,равных 5. ,

Ответ:
1kukukukuku
1kukukukuku
03.10.2020 11:48
1)
var a:array [1..100] of integer;
i,n,k:integer;
begin
readln(n); //количество элементов массива
for i:=1 to n do
read(a[i]); //ввод массива через пробел с клавиатуры
writeln;
readln(k); //ввод значения, номер которого будем искать
for i:=1 to n do
if a[i]=k then writeln(i) //поиск номера введенного элемента
end.
2)
var a:array [1..100] of integer;
i,n,s:integer;
begin
s:=0;
readln(n); //количество элементов массива
for i:=1 to n do
read(a[i]); //ввод массива через пробел с клавиатуры
writeln;
for i:=1 to n do
if a[i]=5 then s:=s+1; //подсчёт кол-ва элементов равнх 5
writeln(s)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?