В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
andreymatv2p0duh5
andreymatv2p0duh5
14.07.2020 16:07 •  Информатика

Напишите программу которая получает с клавиатуры натуральное число которое больше 1 и определяет простое оно или нет. для этого нужно делить число на все натуральные числа начиная с 2 пока не получится деление без остатка repeat и until

Ответ:
matveyking12345
matveyking12345
09.10.2020 23:55

program simple_num;

var n:integer;


function simple(num:integer):boolean;

var count, i:integer;

   key:boolean;

begin

   count := 0;

   i := 1;

   repeat

       if num mod i = 0 then

           inc(count);

       inc(i);

   until (i > num);

   if count > 2 then

       key := false

   else key := true;

   simple := key;

end;


begin

   writeln('Введите натуральное число больше 1');

   readln(n);

   if n > 1 then

       if simple(n) then

           writeln('Число ',n, ' простое')

       else writeln('Число ',n, ' непростое')

   else writeln('введено число менее 1');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?