В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
murat121221
murat121221
05.05.2020 04:45 •  Информатика

Составить программу, которая в одномерном массиве размерностью 15, состоящим из случайных чисел из промежутка от 20 до 80,находится наибольший элемент оканчивающийся на цифру 2 или 8

Ответ:
никита3227
никита3227
27.08.2020 13:52

var a: array[1..15] of integer;

i,m: integer;

begin

writeln('массив:');

for i:=1 to 15 do

begin

a[i]:=random(61)+20;

write(a[i],' ');

end;

m:=-1;

writeln;

for i:=1 to 15 do

if ((a[i] mod 10=2) or (a[i] mod 10=8)) and (a[i]>m) then m:=a[i];

if m=-1 then write('такого элемента нет') else writeln('m=',m);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?