В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
sofiabts
sofiabts
17.09.2022 02:09 •  Информатика

Укого с информатикой хорошо? 9 класс написать программу для нахождения минимального элемента массива а(21). написать программу, находящую номер первого и последнего отрицательного элементов массива y(25). вычислить среднее арифметическое положительных четных элементов массива а(n).

Ответ:
Дашка5милашка
Дашка5милашка
09.10.2020 19:52

#1


var

A : array [1..21] of integer;

min : integer := 32766;

begin

for var i:=1 to 21 do

 readln(A[i]);

for var i:=1 to 21 do

if (A[i] < min) then

min := A[i];

writeln(min);

end.

#2

var

Y : array [1..25] of integer;

isthefirst : boolean := false;

last : integer := 0;

begin

for var i:=1 to 25 do

 readln(Y[i]);

for var i:=1 to 25 do

 if (Y[i] < 0) and (isthefirst = false) then

   begin

   writeln(i);

   isthefirst := true;

   break;

   end;

for var i:=2 to 25 do

begin

if (i = 25) then  

begin

if (Y[i] < 0) and (last = 0) then

last := i;

break;

end;

if ((Y[i+1] > 0) and (Y[i] < 0)) then

last := i;

end;

if (isthefirst) and (last = 0) then

last := 1;

if (last <> 0) then

writeln(last) else

writeln('There''no numbers');

end.

//Не бейте за кастыли Мне лень думать)))000



#2

type TIntMassiv = array of Integer;   //Дин. Массив (Более гибок в работе)


var  

n : integer;

sum : integer := 0;

counter : integer := 0;

var A: TIntMassiv;

begin

readln (n);

SetLength(A, n);

for var i:=0 to n-1 do

begin

readln(A[i]);

if (A[i] > 0) and (A[i] mod 2 = 0) then

begin

sum += A[i];

counter += 1;

end;

end;

if (sum = 0) or (counter = 0) then

begin

writeln('There''re no numbers');

exit;

end;

writeln(sum/counter);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?