В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
тошка12
тошка12
06.01.2022 18:49 •  Информатика

(питон)дан целочисленный массив из 10 элементов. элементы массива могут принимать произвольные целые значения. напишите программу, которая находит и выводит номера двух элементов массива, сумма которых максимальна. исходные данные объявлены так, как показано ниже. a = [] n = 10 for i in range(0, n): a.append(int(

Ответ:
Nemogu999
Nemogu999
09.10.2020 19:29

Пояснение:

Сумма будет максимальной в том случае, если будут суммированы два самых больших числа в массива. То есть необходимо их найти и вывести их индексы. Программа снизу как раз это и вычисляет через два прохода цикла for

a = [] #объявление списка    

n = 10 #кол-во элементов в списке

for i in range(0,n): #заполнение списка

   a.append(int(input('Введите ['+ str(i) + "] элемент: ")))

max_number = 0 #устанавливаем начальный индекс макс. эл.

for i in range(n-1): #поиск индекса макс. эл.

   if(a[max_number] < a[i+1]):

       max_number = i+1

       

if(max_number == 0): #если индекс макс. эл = 0

   pre_max_number = 1 #начальный индекс второго макс. эл. = 1

else: pre_max_number = 0 #иначе 0

for j in range(n-1): #поиск индекса второго макс. эл.

   if(j+1 != max_number and a[pre_max_number] < a[j+1]):

       pre_max_number = j+1

       

print(max_number, pre_max_number) #вывод их на экран

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?