В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
snikola97
snikola97
17.06.2022 18:34 •  Информатика

Дан двумерный массив. определить, есть ли среди элементов массива данное число q. написать программу, . заранее : )

Ответ:
ржакаmaker
ржакаmaker
08.10.2020 02:19
// PascalABC.NET 3.3
const n=7;
begin
  Writeln('Исходный массив:');
  var a:=MatrRandom(n,n,-10,10); a.Println(6);
  var q:=ReadInteger('q = ');
  var m:=a.ElementsByRow.Where(x->x=q).Count;
  if m>0 then writeln('YES') else writeln('NO');
end.

Пример:
Исходный массив:
     0    -1   -10     7     5     5     5
    -3     8     8    -8     4    10     0
    -2     9    -1    -4   -10    -2     2
    -9     6    10    -4     3    -5     4
    -3     9     4    -6     8    10    -2
     4    -1    -2     8     9    -8    -3
     5     6     2     5     9     3     8
q =  9
YES
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?