В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
alexsashinav
alexsashinav
13.05.2022 23:44 •  Информатика

Написать программу. найти количество положительных элементов массива.

Ответ:
oxxximiro1
oxxximiro1
09.10.2020 18:48

Program Massive;

uses Crt;

const N = 10;

var

  A: array [1..N] of Integer;

  i: integer;

  x: integer;

begin

    Randomize;

    for i:= 1 to N do

    begin

      A[i] := Random(101);

      A[i] := A[i] - 50;

    end;

    ClrScr;

    writeln('Massive:');

    for i:= 1 to N do

        write(A[i]:4);

    writeln;

    readln;

    for i:=1 to N do

     if (A[i] > 0) then x:=x+1;

    write ('x = ', x);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?