В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Aigerim735
Aigerim735
14.03.2022 17:49 •  Информатика

Написать программу на яп паскаль для вычисления площади треугольника по его сторонам ab, bc, ca (формула герона). программу написать на 13 строк.

Ответ:
TheGreatHaterMisha
TheGreatHaterMisha
09.10.2020 10:13

//PASCAL ABC.NET

var

 s, p, ab, bc, ca: real;

begin

 read(ab, bc, ca);

 p := (ab + bc + ca) / 2;

 s := sqrt(p * (p - ab) * (p - bc) * (p - ca));

 writeln(p, #10, s);

end.


 

0,0(0 оценок)
Ответ:
ymniupisos
ymniupisos
09.10.2020 10:13

Ровно 13 строк:

program Geron;

var ab,bc,ca,p: real;

begin

writeln('Определение площади треугольника по теореме Герона');

write('Введите сторону треугольника AB: ');

readln(ab);

write('Введите сторону треугольника BC: ');

readln(bc);

write('Введите сторону треугольника CA: ');

readln(ca);

p:=(ab+bc+ca)/2;

writeln('Площадь треугольника равна ',sqrt(p*(p-ab)*(p-bc)*(p-ca)):0:3)

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?