В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Написать программу на с++, используя функции. найти наименьшее общее кратное четырех заданных натуральных чисел.

Ответ:
kofhagje46
kofhagje46
17.08.2020 01:54

#include <iostream>

#define _ std::

int NOD(int a, int b){

return (a == 0) ? b : NOD(b%a, a);

}

int NOK(int a, int b) {

return (a*b) / NOD(a, b);

}

int main() {

int a, b, c, d;

_ cin >> a >> b >> c >> d;

_ cout << NOK(a, NOK(b, NOK(c, d))) << _ endl;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?